Дельные Cоветы [#10]

Программа Microsoft Excel — одна из самых используемых в SEO. В первую очередь с ее помощью обрабатываются списки запросов семантического ядра. Есть несколько простых формул и функций, которые могут помочь обработать большой массив данных. Знают о них, как ни странно, далеко не все.

СЦЕПИТЬ

Очень часто бывает, что в одном столбце находится список запросов, а в другом - URL. Можно быстро сформировать из них ссылочный тег в третьем столбце такой формулой:

=СЦЕПИТЬ("<a href=";"URL";" >";"Запрос";"</a>";)

Остается вытянуть столбец и список ссылок готов. Сцепляйте между собой любые текстовые столбцы. Чтобы слова не сливались, нужно только добавить пробел в кавычках в формулу.

ВПР

Ситуация такова: у вас есть список из 2000 запросов в столбце А с частотностями в столбце B. И у вас еще дополнительный список из примерно 100 запросов без частотностей. Задача — понять, есть ли вообще эти запросы в первом (большом) списке и какова их частотность? Excel поможет нам решить эту задачу за одну минуту.

На Листе 1 у нас список из 2000 запросов, на Листе 2 в столбце А - список из 100 запросов. В столбец B листа 2 пишем такую формулу:

=ВПР(А1;'Лист 1'!$A$1:$B$2000;2;ЛОЖЬ)

Поясню:

  • первая часть формулы — что ищем, то есть запрос из ячейки А1;
  • вторая часть — в каком диапазоне ищем, указываем там Лист 1 и диапазон от ячейки А1 до В2000 и делаем с помощью знаков $ этот диапазон константой (иначе потом при вытягивании столбца он может сбиться);
  • третья часть формулы (цифра 2) — номер столбца, который мы просим показать в этой ячейке (в данном случае это частотность из второго столбца, В)
  • ЛОЖЬ означает что будет производиться точный поиск соответствия.

Вытягиваем столбец В и видим: подгружается либо частотность этого запроса (а значит он в большом списке есть), либо надпись Н/Д (значит такого запроса в диапазоне не обнаружено).

Текст по столбцам

Содержимое любой ячейки легко разбить на отдельные столбцы, используя любой повторяющийся знак. Например, в столбце слова через пробел. Выбираем ячейки столбца, в разделе "Данные" находим кнопку "Текст по столбцам" и в качестве разделителя указываем пробел. Это бывает актуально, если не хочет нормально открываться файл формата csv и вы видите просто строчки, в которых через точку с запятой перечислены какие-то данные.

Включить фильтрацию в столбцах

Функция появилась не так давно, в 2003-ем excel ее точно нет. Выбираем первую строку таблицы (обычно это "шапка", в которой указаны название столбцов) и нажимаем кнопку, похожую на воронку. Теперь справа в ячейках появляется небольшая кнопка с выпадающим списком, нажав которую можно быстро отфильтровать столбец или упорядочить его. Эта функция очень помогает, когда нужно выкинуть мусор из запросов, которые были добыты из Wordstat или других аналогичных сервисов. Например, можно последовательно фильтровать запросы с цифрами (от 0 до 9) и удалять их, выделяя строчки, которые останутся после фильтрации.

 


Координационный
совет SPECIA
Санкт-Петербург,
8-я Красноармейская ул., д.10
На карте
×
Санкт-Петербург,
8-я Красноармейская ул., д.10
info@artw.ru